Documentation ¶
Index ¶
- func CollectManagementClusterAndWorkloadClusterDiagnostics(managementClusterName string, workloadClusterName string, ...) error
- func CollectManagementClusterDiagnostics(managementClusterName string) error
- func DisableContextAwareCliForPluginsGlobally() error
- func GetBootstrapClusterDockerContainerNameForManagementCluster(managementClusterName string) (string, error)
- func GetClientConfig() (*tf.ClientConfig, error)
- func PluginInstall(pluginName string, pathToLocalDiscoveryOrDistributionSource string) error
- func PluginList() error
- func PluginRepoUpdate(repoName string, gcpBucketName string) error
- func PrintAllPluginVersions()
- func PrintTanzuVersion() error
- type EnvVars
- type TanzuConfig
Constants ¶
This section is empty.
Variables ¶
This section is empty.
Functions ¶
func CollectManagementClusterAndWorkloadClusterDiagnostics ¶
func CollectManagementClusterAndWorkloadClusterDiagnostics(managementClusterName string, workloadClusterName string, workloadClusterInfra string) error
TODO: Convert workload cluster infra from string to a type - say iota or similar to get pre-defined (compile time) constants like azure, aws, vsphere, docker
func DisableContextAwareCliForPluginsGlobally ¶
func DisableContextAwareCliForPluginsGlobally() error
Runs `tanzu config set features.global.context-aware-cli-for-plugins false` command
func GetBootstrapClusterDockerContainerNameForManagementCluster ¶
func GetBootstrapClusterDockerContainerNameForManagementCluster(managementClusterName string) (string, error)
TODO: Rename this to a smaller name
func GetClientConfig ¶
func GetClientConfig() (*tf.ClientConfig, error)
func PluginInstall ¶
TODO: Should we rename this to InstallPlugin? TODO: Should we have a better and smaller name for pathToLocalDiscoveryOrDistributionSource? Install a plugin Runs `tanzu plugin install --local <path-to-local-discovery-or-distribution-source> <plugin-name>`
func PluginList ¶
func PluginList() error
TODO: Should we rename this to ListPlugins? TODO: Maybe in the future we can parse the data (with -o json JSON output) and return it List available plugins Runs `tanzu plugin list`
func PluginRepoUpdate ¶
TODO: Should we rename this to UpdatePluginRepo? Update a repository configuration Runs `tanzu plugin repo update --gcp-bucket-name <gcp-bucket-name> <repo-name>`
func PrintAllPluginVersions ¶
func PrintAllPluginVersions()
Where to get the list of plugins from? 1. tanzu plugin list . This also has json and yaml output with `-o` flag 2. check artifact (tar ball, zip) for K8s resource yaml files of kind cli.tanzu.vmware.com/v1alpha1/CLIPlugin inside the directory default-local/discovery/standalone in the artifact 3. Manually put the list - not feasible as list can change for different version
func PrintTanzuVersion ¶
func PrintTanzuVersion() error
Types ¶
type EnvVars ¶
type EnvVars []string
func TanzuConfigToEnvVars ¶
func TanzuConfigToEnvVars(tanzuConfig TanzuConfig) EnvVars
TODO: Should we stick to env vars for cluster config or can we use yaml like tanzu cli consumes